aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--README12
-rw-r--r--config.default.sh21
2 files changed, 30 insertions, 3 deletions
diff --git a/README b/README
index 40689e4..4335876 100644
--- a/README
+++ b/README
@@ -3,10 +3,20 @@ README for aur-fd-scripts - scripts to generate freedict PKGBUILDs
Things are to be written here.
+Configuration:
+--------------
+
+Copy config.default.sh to config.sh, set $maintainer and modify as much as
+you like.
+
+
Usage:
------
-Just call ./update.sh or ./make_install.sh to see usage information.
+Make sure config.sh exists and has the correct $maintainer variable set.
+
+Then, just call ./update.sh or ./make_install.sh. Usage information will be
+displayed.
Dependencies:
diff --git a/config.default.sh b/config.default.sh
index d17b4c1..276f912 100644
--- a/config.default.sh
+++ b/config.default.sh
@@ -1,9 +1,26 @@
#!/usr/bin/env bash
#
-# config.default.sh - some configuration options.
+# Copyright 2018 Einhard Leichtfuß
#
-# Move this file to config.sh and modify to your liking.
+# config.default.sh - default configuration options;
+# copy this file to config.sh and modify to your liking.
#
+# This file is part of aur-fd-scripts
+#
+# aur-fd-scripts is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published
+# by the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# aur-fd-scripts is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with aur-fd-scripts. If not, see <https://www.gnu.org/licenses/>.
+#
+
# The maintainer to be listed in the PKGBUILD.
maintainer="Your Name <your@email-address.tld>"