aboutsummaryrefslogtreecommitdiff
path: root/basic.sh
diff options
context:
space:
mode:
authorEinhard Leichtfuß <alguien@respiranto.de>2018-04-01 01:06:37 +0200
committerEinhard Leichtfuß <alguien@respiranto.de>2018-04-01 01:06:37 +0200
commitfa22a06bad529fccd4083f9a355902e4e5cb09c9 (patch)
tree991298cb764b89eaae4c37e159d9a36005e46cb4 /basic.sh
parent82c373e3e69d4cf028dbad4896129991c8e963c4 (diff)
Set up update.sh for vcs packages
Therefore, use $vcs_langs instead of $langs, due to fra-deu and deu-fra missing in the vcs tree. Furthermore, in - svn/sample.PKGBUILD, `- change the default pkgrel to 2, since any update is forced, i.e. there is no version change asking for update; - update.sh, `- add a usage note, `- require a specific type (e.g. src) to be supplied, `- remove the need to specify $ext for -u, `- set up a handle_all_vcs() function specifically for VCS sources, i.e. svn, `- move the download of freedict-database.json to handle_all().
Diffstat (limited to 'basic.sh')
-rw-r--r--basic.sh7
1 files changed, 7 insertions, 0 deletions
diff --git a/basic.sh b/basic.sh
index 6e90dbc..2220e27 100644
--- a/basic.sh
+++ b/basic.sh
@@ -8,6 +8,13 @@ langs=(
spa-eng eng-spa
)
+typeset -a vcs_langs
+vcs_langs=(
+ deu-eng eng-deu
+ fra-eng eng-fra
+ spa-eng eng-spa
+ )
+
function init
{
tmp_d="$(mktemp -d)"