aboutsummaryrefslogtreecommitdiff
path: root/config.default.sh
diff options
context:
space:
mode:
authorEinhard Leichtfuß <alguien@respiranto.de>2018-12-23 18:31:05 +0100
committerEinhard Leichtfuß <alguien@respiranto.de>2018-12-23 18:31:05 +0100
commit5b9833151caa6c601278a188a3c335a56bc529b1 (patch)
tree5df0761c872669af41786f8469a0ef4de09a207a /config.default.sh
parentf4ef5f217e7efc76adb1218dca11a5345145fae2 (diff)
plit off user-config.sh
Diffstat (limited to 'config.default.sh')
-rw-r--r--config.default.sh92
1 files changed, 0 insertions, 92 deletions
diff --git a/config.default.sh b/config.default.sh
deleted file mode 100644
index 276f912..0000000
--- a/config.default.sh
+++ /dev/null
@@ -1,92 +0,0 @@
-#!/usr/bin/env bash
-#
-# Copyright 2018 Einhard Leichtfuß
-#
-# config.default.sh - default configuration options;
-# copy this file to config.sh and modify to your liking.
-#
-# This file is part of aur-fd-scripts
-#
-# aur-fd-scripts is free software: you can redistribute it and/or modify
-# it under the terms of the GNU Affero General Public License as published
-# by the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# aur-fd-scripts is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU Affero General Public License for more details.
-#
-# You should have received a copy of the GNU Affero General Public License
-# along with aur-fd-scripts. If not, see <https://www.gnu.org/licenses/>.
-#
-
-
-# The maintainer to be listed in the PKGBUILD.
-maintainer="Your Name <your@email-address.tld>"
-
-
-# Dictionaries in the VCS tree, GPL2 assumed.
-typeset -a vcs_langs
-vcs_langs=(
- deu-eng eng-deu
- fra-eng eng-fra
- spa-eng eng-spa
- )
-
-typeset -a wikdict_langs
-wikdict_langs=(
- fra-deu deu-fra
- )
-
-typeset -a langs
-langs=( ${vcs_langs[@]} ${wikdict_langs[@]} )
-
-
-# Long names table.
-typeset -A long
-long[fra]=French
-long[deu]=German
-long[eng]=English
-long[spa]=Spanish
-
-
-# Contributors for some specific PKGBUILDs (indexed by $lang$ext).
-typeset -A contrs
-contrs[deu-eng-bin]=\
-'# Contributor: akane <grangerspit@gmail.com> <xmpp:heiß@neko.im>'$'\n'
-contrs[eng-deu-bin]=\
-'# Contributor: akane <grangerspit@gmail.com> <xmpp:heiß@neko.im>'$'\n'
-contrs[fra-eng-bin]=\
-'# Contributor: Benjamin Vanderford <hazor_at_swrpg_dot_info>'$'\n'
-contrs[eng-fra-bin]=\
-'# Contributor: Benjamin Vanderford <hazor_at_swrpg_dot_info>'$'\n'
-
-# Licenses (indexed by $lang)
-typeset -A licenses
-for lang in ${vcs_langs[@]}
-do
- licenses[$lang]="'GPL'"
-done
-
-for lang in ${wikdict_langs[@]}
-do
- licenses[$lang]="'CCPL:by-sa' 'FDL'"
-done
-
-
-# prepare() functions (indexed by $lang$ext).
-typeset -A prepare
-
-# Does not work for deu-fra-bin, since the index file must stay in sync.
-prepare[deu-fra]=\
-'prepare()
-{
- cd $_lang
- sed -Ei \
- -e '"'"'s/(10)(10)(100\>)(\s+\(10)(Googol.*(1|Eins) mit einem Googol Nullen)/\1^(\2^\3)\4^\5/'"'"' \
- -e '"'"'s/(10)([1-9][0-9]*)(.*(1|Eins) mit \2 Nullen)/\1\^\2\3/'"'"' \
- -e '"'"'s/(die Zahl 10)(60)/\1^\2/'"'"' \
- ${_lang}.tei
-}
-'