aboutsummaryrefslogtreecommitdiff
path: root/general-config.sh
diff options
context:
space:
mode:
authorEinhard Leichtfuß <alguien@respiranto.de>2022-04-29 14:58:55 +0200
committerEinhard Leichtfuß <alguien@respiranto.de>2022-04-29 14:58:55 +0200
commit915faab9c074a0a30b8321c3836d0b35f475e94d (patch)
tree522b4109f2d43ff06db001b329ec1e09884cf6c8 /general-config.sh
parent90a0069d9bb72bf3caf59e2411a144f9e3afd2d3 (diff)
Use proper .bash suffix
Diffstat (limited to 'general-config.sh')
-rw-r--r--general-config.sh89
1 files changed, 0 insertions, 89 deletions
diff --git a/general-config.sh b/general-config.sh
deleted file mode 100644
index 040ec6a..0000000
--- a/general-config.sh
+++ /dev/null
@@ -1,89 +0,0 @@
-#!/usr/bin/env bash
-#
-# Copyright 2018,2022 Einhard Leichtfuß
-#
-# general-config.sh - general configuration options
-#
-# This file is part of aur-fd-scripts
-#
-# aur-fd-scripts is free software: you can redistribute it and/or modify
-# it under the terms of the GNU Affero General Public License as published
-# by the Free Software Foundation, either version 3 of the License, or
-# (at your option) any later version.
-#
-# aur-fd-scripts is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-# GNU Affero General Public License for more details.
-#
-# You should have received a copy of the GNU Affero General Public License
-# along with aur-fd-scripts. If not, see <https://www.gnu.org/licenses/>.
-#
-
-
-# Dictionaries in the VCS tree, GPL2 assumed.
-typeset -a vcs_langs
-vcs_langs=(
- deu-eng eng-deu
- fra-eng eng-fra
- spa-eng eng-spa
- )
-
-# Dictionaries imported from WikDict, hence Wiktionary.
-# Dual licensed: CC-BY-SA, GNU FDL (1.1 or later).
-typeset -a wikdict_langs
-wikdict_langs=(
- fra-deu deu-fra
- )
-
-typeset -a langs
-langs=( "${vcs_langs[@]}" "${wikdict_langs[@]}" )
-
-
-# Long names table.
-typeset -A long
-long[fra]=French
-long[deu]=German
-long[eng]=English
-long[spa]=Spanish
-
-
-# Contributors for some specific PKGBUILDs (indexed by $lang$ext).
-typeset -A contrs
-contrs[deu-eng-bin]=\
-'# Contributor: akane <grangerspit@gmail.com> <xmpp:heiß@neko.im>'$'\n'
-contrs[eng-deu-bin]=\
-'# Contributor: akane <grangerspit@gmail.com> <xmpp:heiß@neko.im>'$'\n'
-contrs[fra-eng-bin]=\
-'# Contributor: Benjamin Vanderford <hazor_at_swrpg_dot_info>'$'\n'
-contrs[eng-fra-bin]=\
-'# Contributor: Benjamin Vanderford <hazor_at_swrpg_dot_info>'$'\n'
-
-# Licenses (indexed by $lang)
-typeset -A licenses
-for lang in "${vcs_langs[@]}"
-do
- licenses["$lang"]="'GPL'"
-done
-
-for lang in "${wikdict_langs[@]}"
-do
- licenses["$lang"]="'CCPL:by-sa' 'FDL'"
-done
-
-
-# prepare() functions (indexed by $lang$ext).
-typeset -A prepare
-
-# Does not work for deu-fra-bin, since the index file must stay in sync.
-prepare[deu-fra]=\
-'prepare()
-{
- cd "$_lang"
- sed -Ei \
- -e '"'"'s/(10)(10)(100\>)(\s+\(10)(Googol.*(1|Eins) mit einem Googol Nullen)/\1^(\2^\3)\4^\5/'"'"' \
- -e '"'"'s/(10)([1-9][0-9]*)(.*(1|Eins) mit \2 Nullen)/\1\^\2\3/'"'"' \
- -e '"'"'s/(die Zahl 10)(60)/\1^\2/'"'"' \
- "${_lang}.tei"
-}
-'