aboutsummaryrefslogtreecommitdiff
path: root/update.sh
diff options
context:
space:
mode:
authorEinhard Leichtfuß <alguien@respiranto.de>2022-04-29 14:45:01 +0200
committerEinhard Leichtfuß <alguien@respiranto.de>2022-04-29 14:50:26 +0200
commit79165e9ef694062703e872ba99a17ee53ca9d4a4 (patch)
tree7f9518dcf3904539d923b388b78d7fe48a81fa35 /update.sh
parent39034cef410d333d10d2a7ab1219b186ca22e4bc (diff)
Consistent quoting
Diffstat (limited to 'update.sh')
-rwxr-xr-xupdate.sh8
1 files changed, 4 insertions, 4 deletions
diff --git a/update.sh b/update.sh
index c6f602d..f011164 100755
--- a/update.sh
+++ b/update.sh
@@ -2,7 +2,7 @@
#
# update.sh - script to check for updates and perform them (on the PKGBUILDs)
#
-# Copyright 2018 Einhard Leichtfuß
+# Copyright 2018,2022 Einhard Leichtfuß
#
# This file is part of aur-fd-scripts
#
@@ -69,7 +69,7 @@ function main
then
handle_all_vcs svn -svn "$@"
else
- echo "Type $type not supported." >&2
+ echo "Type ${type} not supported." >&2
exit 1
fi
}
@@ -137,7 +137,7 @@ function handle_all
cd $lang || exit 1
$nopull || git pull -q
pkgver="$(sed -En 's/\s*pkgver\s*=\s*(.+)\s*/\1/p' .SRCINFO)"
- data="$(jq -r ".[] | select(.name == \"${lang}\") | .releases[] | select(.platform==\"$platform\")" ../../freedict-database.json)"
+ data="$(jq -r ".[] | select(.name == \"${lang}\") | .releases[] | select(.platform==\"${platform}\")" ../../freedict-database.json)"
ver="$(jq -r '.version' <<< "$data")"
url="$(jq -r '.URL' <<< "$data")"
checksum="$(jq -r '.checksum' <<< "$data")"
@@ -186,7 +186,7 @@ function handle_all_vcs
cd "$type" || exit 1
- for lang in ${vcs_langs[@]}
+ for lang in "${vcs_langs[@]}"
do
cd $lang || exit 1
$nopull || git pull -q