aboutsummaryrefslogtreecommitdiff
path: root/update.sh
diff options
context:
space:
mode:
authorEinhard Leichtfuß <alguien@respiranto.de>2018-12-23 16:42:28 +0100
committerEinhard Leichtfuß <alguien@respiranto.de>2018-12-23 16:42:28 +0100
commit92d20f8fd6b0e8036da83abe8e3c4e98b1e8e029 (patch)
tree98e89040ec197202e5b2b628a478d1932f21fefb /update.sh
parentb300f3c047a606024db2098523c8fff70721c716 (diff)
Use $lang instead of $pkgname for dirnames
Diffstat (limited to 'update.sh')
-rwxr-xr-xupdate.sh6
1 files changed, 3 insertions, 3 deletions
diff --git a/update.sh b/update.sh
index b78e062..5ba1556 100755
--- a/update.sh
+++ b/update.sh
@@ -118,7 +118,7 @@ function main
# Update PKGBUILD and .SRCINFO
#
# requires: $lang, $ext, $type, $ver, $convver to be set;
-# $PWD == <base directory>/<type>/<lang's packaging dir>
+# $PWD == <base directory>/<type>/<lang>
#
function update
{
@@ -172,7 +172,7 @@ function handle_all
for lang in ${langs[@]}
do
- cd dict-freedict-${lang}${ext} || exit 1
+ cd $lang || exit 1
$nopull || git pull -q
pkgver="$(sed -En 's/\s*pkgver\s*=\s*(.+)\s*/\1/p' .SRCINFO)"
data="$(jq -r ".[] | select(.name == \"${lang}\") | .releases[] | select(.platform==\"$platform\")" ../../freedict-database.json)"
@@ -226,7 +226,7 @@ function handle_all_vcs
for lang in ${vcs_langs[@]}
do
- cd dict-freedict-${lang}${ext} || exit 1
+ cd $lang || exit 1
$nopull || git pull -q
pkgver="$(sed -En 's/\s*pkgver\s*=\s*(.+)\s*/\1/p' .SRCINFO)"
makepkg --nobuild --nodeps > /dev/null 2>&1