aboutsummaryrefslogtreecommitdiff
path: root/general-config.bash
diff options
context:
space:
mode:
Diffstat (limited to 'general-config.bash')
-rw-r--r--general-config.bash88
1 files changed, 88 insertions, 0 deletions
diff --git a/general-config.bash b/general-config.bash
new file mode 100644
index 0000000..e342b03
--- /dev/null
+++ b/general-config.bash
@@ -0,0 +1,88 @@
+#!/usr/bin/env bash
+#
+# Copyright 2018,2022 Einhard Leichtfuß
+#
+# general-config.bash - general configuration options
+#
+# This file is part of aur-fd-scripts
+#
+# aur-fd-scripts is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published
+# by the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# aur-fd-scripts is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with aur-fd-scripts. If not, see <https://www.gnu.org/licenses/>.
+#
+
+
+# Dictionaries in the VCS tree, GPL2 assumed.
+typeset -a vcs_langs
+vcs_langs=(
+ deu-eng eng-deu
+ fra-eng eng-fra
+ spa-eng eng-spa
+ )
+
+# Dictionaries imported from WikDict, hence Wiktionary.
+# Dual licensed: CC-BY-SA, GNU FDL (1.1 or later).
+typeset -a wikdict_langs
+wikdict_langs=(
+ fra-deu deu-fra
+ )
+
+typeset -a langs
+langs=( "${vcs_langs[@]}" "${wikdict_langs[@]}" )
+
+
+# Long names table.
+typeset -A long
+long[fra]=French
+long[deu]=German
+long[eng]=English
+long[spa]=Spanish
+
+
+# Contributors for some specific PKGBUILDs (indexed by $lang$ext).
+typeset -A contrs
+contrs[deu-eng-bin]=\
+'# Contributor: akane <grangerspit@gmail.com> <xmpp:heiß@neko.im>'$'\n'
+contrs[eng-deu-bin]=\
+'# Contributor: akane <grangerspit@gmail.com> <xmpp:heiß@neko.im>'$'\n'
+contrs[fra-eng-bin]=\
+'# Contributor: Benjamin Vanderford <hazor_at_swrpg_dot_info>'$'\n'
+contrs[eng-fra-bin]=\
+'# Contributor: Benjamin Vanderford <hazor_at_swrpg_dot_info>'$'\n'
+
+# Licenses (indexed by $lang)
+typeset -A licenses
+for lang in "${vcs_langs[@]}"
+do
+ licenses["$lang"]="'GPL'"
+done
+
+for lang in "${wikdict_langs[@]}"
+do
+ licenses["$lang"]="'CCPL:by-sa' 'FDL'"
+done
+
+
+# Optional prepare() function contents (indexed by $lang$ext).
+# - Not necessarily the full function body, but possibly only a part of it.
+# - We cannot assume to be in ${srcdir}.
+typeset -A prepare
+
+# Does not work for deu-fra-bin, since the index file must stay in sync.
+read -r -d '' prepare[deu-fra] << 'EOF' ||:
+cd "${srcdir}/${_lang}"
+sed -Ei \
+ -e 's/(10)(10)(100\>)(\s+\(10)(Googol.*(1|Eins) mit einem Googol Nullen)/\1^(\2^\3)\4^\5/' \
+ -e 's/(10)([1-9][0-9]*)(.*(1|Eins) mit \2 Nullen)/\1\^\2\3/' \
+ -e 's/(die Zahl 10)(60)/\1^\2/' \
+ "${_lang}.tei"
+EOF