aboutsummaryrefslogtreecommitdiff
path: root/update.sh
diff options
context:
space:
mode:
Diffstat (limited to 'update.sh')
-rwxr-xr-xupdate.sh20
1 files changed, 19 insertions, 1 deletions
diff --git a/update.sh b/update.sh
index f1def66..e15d41b 100755
--- a/update.sh
+++ b/update.sh
@@ -1,7 +1,25 @@
-#!/bin/bash
+#!/usr/bin/env bash
+#
+# update.sh - script to check for updates and perform them (on the PKGBUILDs)
#
# Copyright 2018 Einhard Leichtfuß
#
+# This file is part of aur-fd-scripts
+#
+# aur-fd-scripts is free software: you can redistribute it and/or modify
+# it under the terms of the GNU Affero General Public License as published
+# by the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# aur-fd-scripts is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU Affero General Public License for more details.
+#
+# You should have received a copy of the GNU Affero General Public License
+# along with aur-fd-scripts. If not, see <https://www.gnu.org/licenses/>.
+#
+
# usage: $0 dir type [--nopull] [-u xyz-uvw|-ua|-uaf]
# $1 base directory: string
# $2 type: (src|bin|svn)