aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEinhard Leichtfuß <alguien@respiranto.de>2018-03-31 20:29:28 +0200
committerEinhard Leichtfuß <alguien@respiranto.de>2018-03-31 20:29:28 +0200
commit8deb9f854cc26e74e01fcf2199f2d23a4f3ef99a (patch)
tree8fd732a5ecff81a811a3888b7296cf038c30da8b
parent38b8548d4c1fdff888574c0b0ca41b2d67e52bdf (diff)
Add sample PKGBUILD for binary packages.
-rw-r--r--bin/sample.PKGBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/bin/sample.PKGBUILD b/bin/sample.PKGBUILD
new file mode 100644
index 0000000..c8ad522
--- /dev/null
+++ b/bin/sample.PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Einhard Leichtfuß <alguien@respiranto.de>
+%CONTRS%
+_lang=%LANG%
+_pkgname=dict-freedict-${_lang}
+pkgname=${_pkgname}-bin
+pkgver=%VER%
+_pkgver=${pkgver//_/-}
+pkgrel=1
+pkgdesc="%LANG_A% -> %LANG_B% dictionary for dictd et al. from Freedict.org"
+arch=('any')
+url="http://www.freedict.org/"
+license=('GPL')
+optdepends=('dictd: dict client and server')
+provides=(${_pkgname})
+conflicts=(${_pkgname})
+install=${pkgname}.install
+source=("https://sourceforge.net/projects/freedict/files/${_lang}/${_pkgver}/freedict-${_lang}-${_pkgver}.dictd.tar.xz")
+sha512sums=('%CHECKSUM%')
+
+%PREPARE%
+
+package()
+{
+ mkdir -p "${pkgdir}/usr/share/dictd"
+ cp ${_lang}/${_lang}.{dict.dz,index} "$pkgdir/usr/share/dictd/"
+}